Menus won't stay open

Bryrob59's Avatar

Bryrob59

28 Apr, 2013 10:44 PM

The menus for both the slider and tagging will not stay open long enough for me to use them. If I move fast enough I can select from the slider menu before it closes but the tagging menu is unusable.

  1. Support Staff 1 Posted by emolina on 28 Apr, 2013 11:46 PM

    emolina's Avatar

    What jailbreak extensions are you using?

  2. 2 Posted by Bryan Robertson on 29 Apr, 2013 12:32 AM

    Bryan Robertson's Avatar

    None as far as I know.

    ________________________________
     From: emolina <[email blocked]>
    To: [email blocked]
    Sent: Sunday, April 28, 2013 7:46 PM
    Subject: Re: Menus won't stay open [Problems #335]

  3. Support Staff 3 Posted by emolina on 29 Apr, 2013 11:38 PM

    emolina's Avatar

    That's very strange, I've not heard of that behavior before. The menus are handled by the operating system. The only way they would get closed is if you taped somewhere else on the screen. Does it happen every time you open a menu?

  4. 4 Posted by Bryan Robertson on 30 Apr, 2013 02:33 AM

    Bryan Robertson's Avatar

    ________________________________
     From: emolina <[email blocked]>
    To: [email blocked]
    Sent: Monday, April 29, 2013 7:38 PM
    Subject: Re: Menus won't stay open [Problems #335]
     

    Not every time - Sometimes the menus work properly - there is no pattern to it.  I have used the program with the virtual keyboard and an add-on keyboard and with both, it would stay open one time and the next it wouldn't.  I like the program well enough that I can live with it. It's helping me improve my eye-to-hand coordination. :) 

  5. 5 Posted by Grady on 01 May, 2013 07:37 PM

    Grady's Avatar

    This just recently happened to me the other day. May have been the same day. No jail break here. It seems to be functioning fine now. Isn't that strange it occurred in at least two places on relatively yhe same day?

  6. 6 Posted by John Dempsey on 02 May, 2013 02:58 PM

    John Dempsey's Avatar

    I have experienced this during beta testing and did report it. It seems to be triggered by the rotation sensing of the iPad.

    If the iPad is held around the horizontal plane (flat on the desk) then the menu can dissapear as if the iPad thinks you are rotating it and preparing to redraw the screen, although it never does. If you gold it at an angle away from the horizontal it never happens.

    Maybe you are experiencing the same conditions?

    John

  7. 7 Posted by bryrob59 on 03 May, 2013 03:33 AM

    bryrob59's Avatar

    <br/>John - Thanks for the reply and the idea. I think you are correct - Thinking back on when the issue has occurred, It definitely happens when I am working on a flat surface. I seem to recall it happening once when I was working at an angle but I could be mistaken. I will experiment with this and see.<br/><br/>Sent from Yahoo! Mail for iPad

  8. 8 Posted by bryrob59 on 03 May, 2013 03:36 AM

    bryrob59's Avatar

    Grady - See John Dempsey's response. He may be on to something.<br/><br/><br/>Sent from Yahoo! Mail for iPad

  9. 9 Posted by Martin on 15 Jul, 2013 06:09 PM

    Martin's Avatar

    I have this problem too on ipad4. The slider menu disappears too quick to use. Exiting the app and coming back in fixes it for a while but that is inconvenient during a meeting

  10. 10 Posted by John Dempsey on 15 Jul, 2013 08:59 PM

    John Dempsey's Avatar

    Hi Martin

    It also seems to be brought on by having the cover with magnetic auto switch off attached. If you have the iPad without the cover fitted then it doesn't seem to occur. Seems to be a conflict with the iPad rotation sensing and magnetic auto switch off.

    I have reported this to the software author in some detail.

    John

    Sent from my iPad.

  11. 11 Posted by Alan on 09 Oct, 2013 05:13 PM

    Alan's Avatar

    I have the same problem as Martin - iPad 4
    Removed the iPad cover as suggested by John - All working properly.
    Replaced cover - Menu's play hide and seek again.

  12. 12 Posted by FrankV on 20 Dec, 2013 10:51 AM

    FrankV's Avatar

    Exactly the same problem here. Removing the cover helps indeed as a temporary workaround.

  13. 13 Posted by nmgeek on 23 May, 2014 07:20 PM

    nmgeek's Avatar

    I've had this problem for years. I've always thought it was some dysfunctional mode the app gets into so I usually try power cycling the iPad. Sometimes it fixes the bug and sometimes not. I've waited through 3+ software updates for a fix and I'm amazed it was never fixed.

    Knowing that it might be related to the position of the iPad or whether the cover is attached is helpful. I will experiment with that. Every time I can remember the problem occurring I was taking notes in a meeting the cover rolled back to elevate the back side of the device.

  14. 14 Posted by Bronwyn on 26 Jul, 2014 09:05 PM

    Bronwyn's Avatar

    I am having same problem today. Tags won't stay open long enough to edit or add and the slider won't stay open.

    This problem looks like it has been around for two years. Got this app yesterday and having trouble using it because the menus won't co-operate.

  15. 15 Posted by John on 25 Aug, 2014 02:44 PM

    John's Avatar

    It happens to me very often. My iPad is not jailbreaked and it does not happen in any other Apps.

  16. 16 Posted by Martin on 25 Aug, 2014 06:54 PM

    Martin's Avatar

    This was solved for me some time ago, recall it being the Apple supplier cover, the one that clips on magnetically and has four folds.

     

    Buy a standard cover, I ended up with a Jammy Lizard cover which is very nice, and now almost forgotten about this problem.

  17. 17 Posted by Bronwyn on 25 Aug, 2014 08:24 PM

    Bronwyn's Avatar

    Martin, it's the menus in the app that don't stay open! Nothing to do with physical covers.

  18. 18 Posted by Bronwyn Patters... on 25 Aug, 2014 09:22 PM

    Bronwyn Patterson's Avatar

    Martin, it's the menus in the app that don't stay open! Nothing to do with physical covers.

    Sent from my iPad

  19. 19 Posted by Martin on 26 Aug, 2014 08:36 AM

    Martin's Avatar

    That’s right, but it is caused by the magnetic clip of the cover interfering with the tilt mechanism.

     

    See post from John Dempsey and Alan above. They solved the issue.

     

    Try a) removing the cover or b) locking the rotate with the switch

  20. 20 Posted by Martin on 26 Aug, 2014 08:54 AM

    Martin's Avatar

    Just to add a bit of detail, try opening the menu then rotating the screen, you will see that the menu closes. This may be controlled by the ipad and not the software developer themselves, so they may not be able to create a fix for it, the IOS itself is closing all menus in preparation to rotate the screen.

     

    What happens is the magnetic cover interferes with the tilt sensor and the software immediately closes the menus even though the screen has not been physically rotated, nor does the screen the rotate. It’s like it’s a little jumpy and prematurely closes the menu even though the full rotation has not been triggered.

     

    As another example, go into Safari, open your bookmarks and then rotate the screen, you will notice the menu does not rotate, it disappears, then it rea-appears once the screen is rotated. This disappearance is what is being triggered incorrectly by the magnetic cover

  21. 21 Posted by Bronwyn on 26 Aug, 2014 09:04 AM

    Bronwyn's Avatar

    Oh, I see what you mean. Completely forgot my case has magnets in it. That makes sense.

    Good to know as I am building an app at the moment and thought this was a code problem!

    Cheers :)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac